Temporary email delay
Incident Report for D3M
Resolved
This incident has been resolved.
Posted Feb 28, 2019 - 07:46 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 27, 2019 - 10:35 EST
Identified
All transactional emails have been halted temporarily, these include:

- Member invites
- Share notifications
- Password reset emails

If you require a password reset, please contact support@d3mnetworks.com
Posted Feb 27, 2019 - 10:33 EST
This incident affected: D3M.